IP500V2 Update schlägt fehl mit dem HTTP Fehler “400 Bad request”

Switch to English

Im Tek-Tips IP Office Forum habe ich kürzlich von Problemen beim Update auf das aktuelle 11.0 FP4 SP1 gelesen. Das Update schlägt während der Dateiübertragung fehl und im Monitor ist die HTTP Fehlermeldung „400 Bad Request“ zu sehen.

Der Benutzet splittingcodec hat den Grund dafür herausgefunden und einen Workaround veröffentlicht. Er hat festgestellt, dass einige Dateien im MemoryCards Ordner des Managers leer sind. Die Lösung war es, in diesen Dateien einen Inhalt einzupflegen. Tragt zum Beispiel den Namen der Dateien ein und speichert diese.

Die von splttingcodec genannten Dateien sind:

  • GUID-D34E8070-85A7-4267-8637-7277A9001AE4.map im Common\system\primary\WebMgmtEE\selfadmin_help\Cloud\<all language folders> Verzeichnis
  • GUID-353430D7-191F-4115-BFB4-C329139187AA.map im Common\system\primary\WebMgmtEE\selfadmin_help\Premise\<all language folders> Verzeichnis
  • Version.json im Common\system\primary\WebMgmtEE Verzeichnis

Anschließend könnt Ihr das Update erneut starten und alles sollte funktionieren wie gewohnt.

Noch einmal vielen Dank an splittingcodec für das Teilen dieser Lösung unter https://www.tek-tips.com/viewthread.cfm?qid=1796408

Update: Avaya hat ein Dokument veröffentlicht, in dem das Problem beschrieben wIrd: https://support.avaya.com/ext/index?page=content&id=SOLN342353

Der Workaround von Avaya ist ein Update über die Manager-Option, die SD-Karte neu zu erstellen. Ich mag diesen Weg eine IPO zu aktualisieren zwar, allerdings hilft das nicht, wenn man nicht vor Ort ist.

Update: Avaya hat die Informationen aktualisiert und die fehlerhaften Dateien zum Austausch zur Verfügung gestellt: https://support.avaya.com/ext/index?page=content&id=SOLN342353

Falls Ihr weitere Hilfe mit einer IP Office benötigt, könnt Ihr mich gern über meine Webseite kontaktieren: https://www.fwilke.com

Wollt Ihr über neue Beiträge informiert werden? Dann registriert Euch doch zu meinem Newsletter

5 Gedanken zu „IP500V2 Update schlägt fehl mit dem HTTP Fehler “400 Bad request”

  1. Pingback: IP500V2 Upgrade fails with HTTP error “400 Bad request” - Blog: Florian Wilke

  2. Jersey Darwinkel

    Hallo, wo findet man die Ordner? wenn ich in die IPO rein schaue, sind die Ordner nicht vorhanden.

    MfG Herr Darwinkel

    Antworten
    1. Florian Beitragsautor

      Hallo Jersey (Du ist OK?),

      Es geht um die Dateien, die im Manager Verzeichnis auf dem PC. Die Dateien liegen unterhalb von C:\Program Files (x86)\Avaya\IP Office\Manager\MemoryCards

      Ich hoffe, das hilft Dir weiter.

      Beste Grüße, Florian

      Antworten
      1. Jersey Darwinkel

        Hallo Florian,

        Du geht in Ordnung. Deine Beschreibung war für mich ein bisschen konfus. Nach einer gewisse zeit habe ich es verstanden. Die Datein die du meinst haben 0 KB, daher muss man irgendwas rein schreiben damit sie 1 KB kriegen, somit die Daten rüber kopiert werden. Für Version.json muss man es einmal machen. Für die anderen beiden muss man jeden Sprachordner (de, en, es, fr, it, pt, ru, zh) nach schauen. Danach läuft das Update durch.

        MfG Herr Darwinkel
        PS: In Cloud muss man “en” nicht machen, da die Datei dort nicht vorhanden ist.

        Antworten
        1. Florian Beitragsautor

          Hallo Jersey,

          Danke für Dein Feedback. Gut, dass es klarer geworden ist. Ich hoffe, Dein Feedback hilft auch anderen.

          Gruß, Florian

          Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.